SledNutZ

SledNutZ (http://www.slednutz.com/index.php)
-   Tech Info (http://www.slednutz.com/forumdisplay.php?f=29)
-   -   need help with my 2005 polaris rmk (http://www.slednutz.com/showthread.php?t=4586)

2005rmk 03-08-2010 11:55 PM

need help with my 2005 polaris rmk
 
was wondering if someone could help me out. I bought an 05 rmk 900 about two years ago. it was moded to a 975 and now take 110 octane. about a month ago was riding and the idle started acting up. it would die if i didn't give it gas and would jump around at half to full throttle. took it to local shop to plug into comp and came out saying TPS sensor, they repositioned it and still same problems as before. my ? is what else could it be? was thinking my fuel injectors might be clogged up, but don't want to start fixing if don't know for sure. should i put a new TPS in and go from there? any help would be greatly appreciated. thanks

Powersledder 03-09-2010 06:05 AM

Check your intake boots, could be cracked and letting in extra air.

OCR 03-09-2010 07:41 AM

Injector issues would be throwing a trouble code too.
Put some seafoam through it to rule them out.

I would test for any air leaks, that can cause the poor low end running conditions you are experiencing.

2005rmk 03-09-2010 11:58 AM

I had noticed a crack in my airbox, but my local shop said not to worrie about it. would that be part of it?

OCR 03-09-2010 02:18 PM

No, that would not cause the problems that you are having.

2005rmk 03-09-2010 02:34 PM

cool going to try the seafoam and check for leaks will let you know how it goes. thanks for your advice.

2005rmk 03-09-2010 02:59 PM

one more thing... if i use this seafoam, would it matter if im using 110 octane 40/60 mix 40 % 110 and 60% 91? and do i just dump it into the gas tank? thanks guys.

OCR 03-09-2010 03:09 PM

Use 6oz in 12 gal of gas.

Powersledder 03-09-2010 04:30 PM

You're other problem could be as simple as the gas you're using. What elevation are you riding at and how do you mix your gas(both % and how you physically mix it)

2005rmk 03-09-2010 07:14 PM

im using 40% 110 and 60% 91. so for a 10gal tank 4gal 110 6gal 91.
i just mix it in the sled tank.

im usually riding between 6 and 9 thousand feet.

i bought the sled from my neighbor and he said to use that ratio. worked fine for me last year, in utah and jackson hole.

any suggestions on how i should be doing this would be greatly appreciated.

Powersledder 03-10-2010 05:22 AM

Contact the shop that did the 975 kit(carls?) you may be running too high of an octane. I know of a 975 here(around 500' elevation) that is running around a 50/50 mix of 110/91.


All times are GMT -5. The time now is 10:02 PM.

Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright 2007 Slednutz.com