SledNutZ

SledNutZ (http://www.slednutz.com/index.php)
-   Polaris General Discussion (http://www.slednutz.com/forumdisplay.php?f=28)
-   -   05 xcsp need help!!! (http://www.slednutz.com/showthread.php?t=6808)

Larry 01-14-2014 12:42 PM

05 xcsp need help!!!
 
Hi everyone. I'm new to the forum so be gentle please.....I bought back in 05 a brand new 05 500 xcsp. Rode it the first season and barley broke it in. Put it away with only 139 miles. It was held hostage up at my friends cabin and wasnt used at all since 05. I rescued it a month ago and am looking forward to finally riding again. It started but ran terrible and knew the carbs needed to be cleaned out. I dropped it off at a local shop. They tried getting me for every dollar i had. They told me my compression was at 105psi. I dont even think the thing is fully broken in and thats why the compression is so low.......just looking for reassurance on that. Does anyone have any advise on this? Am i asking for trouble taking it out on the trails??

OCR 01-14-2014 02:42 PM

You should take it back and do the work yourself.

Ibreakstuff 01-14-2014 11:39 PM

Don't ride it until you go through it. Who knows what made a nest where, and the carbs have to be cleaned.

Powersledder 01-15-2014 08:57 AM

clean the carbs, check the VES valves, pull the plugs and look into the cylinders for nests, pull the exhaust and check for nests, while you have the carbs off check the reeds and carb boots.

Add a little oil to each cylinder through the park plug holes. your rings could be rusted/frozen to the pistons.


All times are GMT -5. The time now is 07:52 AM.

Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright 2007 Slednutz.com