slednutz tech lounge
 

Go Back   SledNutZ > On the Snow... > Classifieds > Suspension/Tracks/Skis/Traction
Ibreakstuff Says: Time to start the snow dance!
Register FAQSled Chat Members List Casino Media Garage Search Today's Posts Mark Forums Read Statistics

SledNutZ Quick Info
Friends of SledNutZ: JohnDee
GreenHulk.net PWC forums
Great Lakes Jeep Thing
Team Belly Pan Sled Forums
PEPPERMILL RENTALS IN THE YOOP! There's no where better to stay in the Rockland/Mass area!
Web hosting by Floogy

M-10 Front Torque arm

Suspension/Tracks/Skis/Traction

 
 
Thread Tools Display Modes
  #1  
Old 11-21-2011
wyndyrider
600 IQ HO LX
wyndyrider's Info
 
Join Date: Nov 2011
Location: Cicero,New York
Posts: 6
Default M-10 Front Torque arm

Has anyone had a problem with their front torque arm on their M-10 suspension? I've read some reports on the front arm breaking and wiping out the track and other parts,and this is with relatively low miles on the sled.Is there a heavy duty replacement for this part? From what I read Polaris doesn't make a heftier replacement part.A man in Canada was making them ,but that was in 2010.
Reply With Quote
  #2  
Old 11-23-2011
PolarisRich's Avatar
PolarisRich
Resident Canadian
PolarisRich's Info
 
Join Date: Sep 2007
Location: Belle River, Ontario, Canada
Posts: 2,402
Send a message via MSN to PolarisRich
Default

I belive your talking about the top gussets on the front Torque Arm?

I've heard of this problem before and from what I heard was the problem is with more so the Polaris version of the M-10. The Fast M-10 version seems to hold up a little better due to a thicker tube wall but still has some problems. The first sign's of the problem is when the paint around the weld on the gusset starts to flake off. This is do to the constant flexing of this weld. I took my front Torque Arm off when I noticed the paint peeling and during the inspection of the weld I found a few hair line cracks. I cleaned and welded the gusset and then added a strip of steel all the way around to re-enforce the gusset and welded it all together. Finished it off with a coat of paint and all was good for the next few years. I was hard on my suspension and was fine.
Reply With Quote
  #3  
Old 11-26-2011
wyndyrider
600 IQ HO LX
wyndyrider's Info
 
Join Date: Nov 2011
Location: Cicero,New York
Posts: 6
Default TeamFast torque arm

Quote:
Originally Posted by wyndyrider View Post
Has anyone had a problem with their front torque arm on their M-10 suspension? I've read some reports on the front arm breaking and wiping out the track and other parts,and this is with relatively low miles on the sled.Is there a heavy duty replacement for this part? From what I read Polaris doesn't make a heftier replacement part.A man in Canada was making them ,but that was in 2010.
I e-mailed TeamFast,They have a heavy duty torque arm for the POLARIS MADE M10 skid at a cost of $399.99.I'm going to take mine off and have it reworked.The main problem seems to be,that Polaris used thinner tube stock when they manufactured the torque arm for their own M10,the arm flexes and the welds crack around the gussets.I think I'm going to disassemble the arm and slide square stock chrome molly over the tube stock and weld it accordingly,the security will be worth the few extra pounds.I wish we as consumers could force Polaris to do a recall on this.Automobiles are constantly having recalls for safety problems,surely this a safety problem.I'm going to e-mail NYSSA and inquire about how to get Polaris to open their eyes.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 03:25 PM.


Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright 2007 Slednutz.com