slednutz tech lounge
 

Go Back   SledNutZ > On the Snow... > Polaris > Tuning
Ibreakstuff Says: Time to start the snow dance!
Register FAQSled Chat Members List Casino Media Garage Search Today's Posts Mark Forums Read Statistics

SledNutZ Quick Info
Friends of SledNutZ: JohnDee
GreenHulk.net PWC forums
Great Lakes Jeep Thing
Team Belly Pan Sled Forums
PEPPERMILL RENTALS IN THE YOOP! There's no where better to stay in the Rockland/Mass area!
Web hosting by Floogy

leaking coolant

Tuning

 
 
Thread Tools Display Modes
  #1  
Old 12-04-2007
rock2324's Avatar
rock2324
2005 700 XCSP,2008 700 Dragon Switchback
rock2324's Info
 
Join Date: Oct 2007
Location: St.Paul Park,MN
Posts: 3,638
Default leaking coolant

ok guys need some help here....I have a 2003 500 xcsp that Is leaking coolant out of the overflow bottle. I dont know why it would do this!,it did not over heat and the overflow bottle is empty, can someone please help? by the way I rode it for about 10 miles.
Reply With Quote
  #2  
Old 12-04-2007
Ibreakstuff's Avatar
Ibreakstuff
Asswipe Admin
Ibreakstuff's Info
 
Join Date: Aug 2007
Location: Burbs
Posts: 8,466
Send a message via MSN to Ibreakstuff
Default

Did you recently fill it up, like to top it off? If so you may have overfilled and when it expanded from the heat it bubbled out.
__________________
You don't have to flinch for me to know that you're scared.
Reply With Quote
  #3  
Old 12-05-2007
rock2324's Avatar
rock2324
2005 700 XCSP,2008 700 Dragon Switchback
rock2324's Info
 
Join Date: Oct 2007
Location: St.Paul Park,MN
Posts: 3,638
Default

well my son and I put on 104 miles last night and it ran flawlessly........never over heated but when we got back and checked coolant level it was down to the add mark again......It never had a problem last year, could the cap be bad?....by the way Ibreakstuff......the avatar...
Reply With Quote
  #4  
Old 12-05-2007
Ibreakstuff's Avatar
Ibreakstuff
Asswipe Admin
Ibreakstuff's Info
 
Join Date: Aug 2007
Location: Burbs
Posts: 8,466
Send a message via MSN to Ibreakstuff
Default

Are you sure it's bubbling out, maybe you have a leak somewhere or a bad head gasket.

You can "rent" a coolant pressure tester at just about any local parts store. You put it where your radiator cap goes, and pump it up like a beer keg. It has a guage on it and if it drops, you have a leak somewhere.
__________________
You don't have to flinch for me to know that you're scared.
Reply With Quote
  #5  
Old 12-05-2007
rock2324's Avatar
rock2324
2005 700 XCSP,2008 700 Dragon Switchback
rock2324's Info
 
Join Date: Oct 2007
Location: St.Paul Park,MN
Posts: 3,638
Default

it seems to hold the pressure,when we opened up last night it hissed at us. I will go get one of those pressure testers and check it out though.thanx for the help.
Reply With Quote
  #6  
Old 12-05-2007
PolarisRich's Avatar
PolarisRich
Resident Canadian
PolarisRich's Info
 
Join Date: Sep 2007
Location: Belle River, Ontario, Canada
Posts: 2,402
Send a message via MSN to PolarisRich
Default

Sounds like a bad Pressure Cap to me. I've had this happen before and it wad the Pressure Cap!
Reply With Quote
  #7  
Old 12-05-2007
YentnaTinker
340 Fanner
YentnaTinker's Info
 
Join Date: Oct 2007
Location: Wasilla, AK
Posts: 5
Send a message via MSN to YentnaTinker
Default

If its the head gasket it will push coolant into the bottle when you first start it. After it warms up it will run fine because the heat will sometimes seal the leak. One indicator of this is when you take the cap off the bottle the coolant level will change a lot sometimes pushing coolant back into the bottle from the engine. Even if its the head gasket it is a fairly quick simple fix.
Reply With Quote
  #8  
Old 12-14-2007
rock2324's Avatar
rock2324
2005 700 XCSP,2008 700 Dragon Switchback
rock2324's Info
 
Join Date: Oct 2007
Location: St.Paul Park,MN
Posts: 3,638
Default

well after all the testing of the cooling system I found the problem:a bad radiator cap....what a pain.....press tested the system and was fine held pressure for 8 hrs.....put a new cap on it and it runs beautiful once more.thanks for the help folks.:D
Reply With Quote
  #9  
Old 12-15-2007
PolarisRich's Avatar
PolarisRich
Resident Canadian
PolarisRich's Info
 
Join Date: Sep 2007
Location: Belle River, Ontario, Canada
Posts: 2,402
Send a message via MSN to PolarisRich
Default

Your Welcome!!!
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:43 AM.


Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright 2007 Slednutz.com