slednutz tech lounge
 

Go Back   SledNutZ > On the Snow... > Polaris > Polaris General Discussion
Ibreakstuff Says: Time to start the snow dance!
Register FAQSled Chat Members List Casino Media Garage Search Today's Posts Mark Forums Read Statistics

SledNutZ Quick Info
Friends of SledNutZ: JohnDee
GreenHulk.net PWC forums
Great Lakes Jeep Thing
Team Belly Pan Sled Forums
PEPPERMILL RENTALS IN THE YOOP! There's no where better to stay in the Rockland/Mass area!
Web hosting by Floogy

can't figure out what is wrong with 98Storm

Polaris General Discussion

 
 
Thread Tools Display Modes
  #1  
Old 10-19-2011
wiguy85
AGE Troop
wiguy85's Info
 
Join Date: Oct 2009
Location: WI
Posts: 41
Default can't figure out what is wrong with 98Storm

Last winter, when i had it all together with different gears and clutching, it still "boged" at midthrottle like it was shifting into overdrive and RPMS would drop until i hit the throttle again. (it has done this with stock clutch/gearing and with the stuff i put on.) The primary has been changed 3 times and secondary has been rebuilt a few times too. Would jackshaft and driveshaft bearings cause this?? I have a seal out on the drive chaincase side but bearing felt good and speedo still works for otherside. When i got it, it would run like a raped ape. After 3rd ride, its been like this ever since. Can't even get the speedo past 80 now!!! Pissing me off. I'm not sure what else it could be! It seems like it shifts down while pulling the engine down a bit and when i hit the gas, it pulls but only pulls to the rest of the RPMS but speed doesn't increase that much, like i said 80ish-90? The motormounts seem good and solid but could very well be worn out i guess. Won't have a chance to put clutch alignment tool til i get back to the states and get it home. The clutch components should be good. I'm out of ideas what it would be. Like i said it was fine the first few rides then started doing this (the first year before i even started tinkering with it) I'm not sure if motormounts would make it do that after a few rides then make it do what its doing now.. Please help with some ideas
Reply With Quote
  #2  
Old 10-19-2011
Ultra Willie's Avatar
Ultra Willie
BIG STONES
Ultra Willie's Info
 
Join Date: Oct 2009
Location: Virginia,MN
Posts: 466
Default

Any time you have seals leaking it's not good. When you checked the bearing did you check it with all the pressure off the shaft? What I mean by this is, taking the skid out and taking all the weight (track included) off the drive sprockets, then check both ends of the drive shaft. definitaly sounds like a binding problem
__________________
Life's journey is not to arrive safely at the grave,but rather to slide in sideways,worn out,shouting what a fuck'n ride!!

MUD '12
Reply With Quote
  #3  
Old 10-19-2011
Madcow's Avatar
Madcow
1050 one lunger
Madcow's Info
 
Join Date: Sep 2007
Location: pine city mn.
Posts: 5,057
Default

does it bog and then give a backfire?

i would look at the needle setting on the carbs, to high of needle and it will bog from over fuel. to low of needle and it will bog from lean condition.
__________________
If the boner police are here I need a lawyer.

in a time of deciet telling the truth is a revolutionary act. george orwell.

aint no body ripin like me. M to the a-d-c-o-w. rock it hard for my fly ladies. I rock it yes in deed. homies still roll with me. money dont change me


nothing goes like 3 holes.

BRTECH HOODS
high performance engineering
aaen performance
millennium technologies
Reply With Quote
  #4  
Old 10-20-2011
wiguy85
AGE Troop
wiguy85's Info
 
Join Date: Oct 2009
Location: WI
Posts: 41
Default

I check it with skid out but can't remember how it felt. I remember it rolled freely though. No signs of bearing chatter or anything but either way its getting all fixed. I remember my cousin telling me the chain was stretched so put a new one in and if i can remember correctly, the oil looked kinda shitty then so the seal was probably already going, just not sure if that would make the whole sled do this consistently, and the shaft still spins free. I've never messed with the carb except dropping the main down a size or two. No backfire, sounds like engine is running good, just something isn't letting the sled ride the way it should. I've thought about the carbs but seems midthrottle is good, just seems to get pulled down if i steady throttle it. I can't remember the speed/RPMS off top of my head but ill try to get somewhat close. If slowly givin it gas when cruising, lets say takin it up to about 50mph at 6500RPMS, then look at the tach and watch it drop down to 5000RPM like its a manual tranny upshifting into overdrive and speed will just kind of hang there. Then crack the throttle and RPMs climb fast and the speed kind of goes up fast but its like it runs out of clutch and tops out at 80/90. It feels just like a clutching problem but can't be!! At first i thought it was a clutch problem cuz they were dirty has hell but after a few clutch rebuilds and clutch swaps, no such luck. It does it with the current clutch on it too and i know that is a good clutch, thing looks beautiful! The engine and all has been rebuilt but still does it. First few times, ran like a top and the only thing i did was put gas in it. Then started doing it and still all i did was put gas in it, no tinkering, all different times of day/temps.

Last edited by wiguy85 : 10-20-2011 at 04:34 AM.
Reply With Quote
  #5  
Old 10-20-2011
wiguy85
AGE Troop
wiguy85's Info
 
Join Date: Oct 2009
Location: WI
Posts: 41
Default

***addition to the carb question. Main jets and many carb cleanings.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

vB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump


All times are GMT -5. The time now is 01:27 PM.


Powered by vBulletin® Version 3.6.8
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Copyright 2007 Slednutz.com